No log entries on server side created when using Nlog

Nov 12, 2013 at 1:53 PM
I finally implemented the Clog for silverlight using the NlogStrategy. My web.config looks like this:
<configSections>
<section name="Clog" type="DanielVaughan.Logging.Configuration.ClientLoggingConfigurationSectionHandler, DanielVaughan.Logging"/>
</configSections>
.
.
.
<Clog xmlns="http://danielvaughan.orpius.com/Clog/2/0/"
    InternalLogLevel="All" SkipFrameCount="4">
<LogStrategy Name="Simple"
       Type="ExampleWebsite.SimpleLogStrategy, ExampleWebsite">
  <Filter Name="IPAddressRange"
      Type="DanielVaughan.Logging.Filters.IPAddressRangeFilter, 
                  DanielVaughan.Logging"
      Begin="127.0.0.0" End="127.0.0.10"/>
</LogStrategy>
<LogStrategy Name="NLog"
    Type="DanielVaughan.Logging.LogStrategies.NLogStrategy, 
              DanielVaughan.Logging.NLogStrategy">
  <Filter Name="IPAddressRange"
      Type="DanielVaughan.Logging.Filters.IPAddressRangeFilter, 
                  DanielVaughan.Logging"
      Begin="127.0.0.0" End="127.0.0.10"/>
</LogStrategy>
</Clog>

The LogManager is recognized and there are entries written to the list but it seems the logs are not passed to the server side. Is there something missing in my config.

I am using Silverlight combined with a RIA service and Nlog for serverside logging.

Any ideas?
Coordinator
Nov 12, 2013 at 6:02 PM
Did you try removing the Filter elements?
Nov 13, 2013 at 7:40 AM
I removed the Filter elements, same result, one question by side, do I really need the configuration for Simple or can I remove that also when using only Nlog ?

<Clog xmlns="http://danielvaughan.orpius.com/Clog/2/0/"
    InternalLogLevel="All" SkipFrameCount="4">
<LogStrategy Name="Simple"
       Type="ExampleWebsite.SimpleLogStrategy, ExampleWebsite">
</LogStrategy>
<LogStrategy Name="NLog"
    Type="DanielVaughan.Logging.LogStrategies.NLogStrategy, 
              DanielVaughan.Logging.NLogStrategy">
</LogStrategy>
</Clog>

In the Debug mode I can see that the logging is called correct and that the entries are done within the LogList but the logEntrySent Value is always NULL:

error NULL
logEntrySent NULL
logList Count=1
logListLock {object}
writeRequested NULL

I have referenced the Logging and Logging.NLogStrategy within my PresentationLayer where the web.config as shown above the NLog.config and the ClogService.svc are located.

Within my modules I referenced the Logging.Silverlight and call the Logmanager as described:
    static readonly ILog log = LogManager.GetLog(typeof(DigiViewUnit_View));

    public DigiView_View()
    {
        InitializeComponent();
        log.Info("DigiView loaded");
.
.
.

I am using Silverlight 5 could that be a problem or am I missing something ?
Cheers!